Connect your Cisco Router to Internet.

Sadananda.S
2 min readSep 26, 2022

Internet connection for devices which passes through Cisco Router

Here we are going to discuss how to provide internet access to the Cisco router. We are using GNS3 as a platform.
To provide internet access to a router there are certain things to be considered. like Routing, NAT, and Access-list.

Let’s talk about Configuration. we have used Host(Firefox), Ethernet Switches, NAT model and Cisco Router.

Configuration

Steps to Configure:

  1. Configure the Outside interface with DHCP or static Ip.
  2. set default route with next hop as the gateway of Outside Interface i.e., In my case 192.168.122.1
  3. Resolve DNS (Optional). try pinging the internet from the router.
  4. Configure the Inside Interface with Router as DHCP Server or configure static addresses.
  5. Configure NAT with Access-list to translate internal Ip addresses to external and provide access for internal IPs to the Internet.
  6. Please refer commands below to configure.
# Configuring Outside interface which is connected to internet.R1#conf t
R1(config)#int fa 1/0
R1(config-if)#ip address dhcp
R1(config-if)#no shut
R1(config-if)#exit
# Configuring default route.R1#conf t
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.122.1
R1(config)#exit
# Configuring domain-lookup to resolve DNS.R1#conf t
R1(config)#ip domain-lookup source-interface fa 1/0
R1(config)#exit
# Now router can ping DNS.# Now configure INSIDE interface with DHCP and NAT.R1(config)#int fa 0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#ip dhcp excluded-address 10.10.10.1 10.10.10.10
R1(config)#ip dhcp pool INSIDE
R1(dhcp-config)#network 10.10.10.0 255.255.255.0
R1(dhcp-config)#default-router 10.10.10.1
R1(dhcp-config)#dns-server 8.8.8.8 8.8.4.4
R1(dhcp-config)#exit
R1(config)#exit
#NAT configurationR1(config)#int fa 0/0
R1(config-if)#ip nat inside
R1(config-if)#exit
R1(config)#int fa 1/0
R1(config-if)#ip nat out
R1(config-if)#ip nat outside
R1(config-if)#exit
R1(config)#ip access-list extended NAT-CONFIG
R1(config-ext-nacl)#permit 10.10.10.0 0.0.0.255 any
R1(config-ext-nacl)#end
#Basic troubleshooting commandsshow ip interface brief
show ip dhcp binding
show ip dhcp pool
show ip nat statistics
show ip nat translations

Internet access to the router and devices installed inside it is a basic network design that needs to be configured.

--

--

Sadananda.S

Network Engineer | AWS | Python Automation | Cybersecurity